
AP Computer Science Summer Assignment  
Part A 

Read selected sections of The Cartoon Guide To Computer Science  
Accessing these will require you to login to the school website and access the following link: 
http://www.veronaschools.org/Page/3140 
 
Use the book and the web if necessary to find answer the questions.  The book was originally 
written in 1983, so keep in mind that some of the terminology is a little archaic (but useful to 
know) and some of the numbers describing the capabilities of modern computers are dated to the 
early 1980’s.   
 
Part I : Ages of Information 
Part I is a relatively easy read.  It reads like a history lesson. 
 
1. Who was Claude Shannon and why was he important?  Where did he do his groundbreaking 

work? 
 
 
 
 
2. What is Shannon’s definition of information? 
 
 
 
3. Why is “life itself” information? 
 
 
 
 
4. What were the earliest examples of information storage? 
 
 
 
5. What Chinese innovation made it easier for humans to do computation? 
 
 
6. What Indian innovation made it easier for humans to do computation? 
 
 
7. How long have humans used “calculators?” 
 
 
8. Who was Al-Khwarismi and what important words/concepts live on as his legacy? 
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9. What does the Latin work “Calx” mean and what English words did this Latin root spawn? 
 
 
10. Who was Isaac Newton and which classes at VHS exist to study his innovations? 
 
 
 
11. Who was John Napier and what two major innovations did he bring to math/computation? 
 
 
 
12. Blaise Pascal invented a computer called the “Pascaline”.  For what else is he remembered? 
 
 
 
13. Who was Gottfried Leibniz and why did he get in a big fight with Newton? 
 
 
 
14. What was Jacquard’s Loom and why was it an important development? 
 
 
 
15. Sketch a diagram of the four major part of Babbage’s Analytical Engine and show the 

information flow between those parts with arrows 
 
 
 
 
 
 
 
 
16. Who Ada Lovelace?  Define three important programming concepts which she developed. 
 
 
 
 
 
17. Herman Hollerith built one of the first “electromechanical” computers.  What does that mean?  

Why did he build it and which modern technology company owes its birth to Hollerith? 
 
 



 
 
18. Another of Hollerith’s inventions was the “Hollerith String.”  What is a Hollerith String and why 

was that an important innovation? 
 
 
19. What is the function of an electromechanical relay and vacuum tube? 
 
 
 
20. What were the advantages and disadvantages of a vacuum tube over an electromechanical 

relay? 
 
 
 
21. The Mark I was an “electromagnetic” computer.  What does that mean? 
 
 
 
22. ENIAC was the first “electronic” computer.  What does that mean? 
 
 
23. How did the US Army use ENIAC? 
 
 
24. What key concept did John von Neumann have which streamlined the way computers work 

today? 
 
 
25.  Name three advantages of the “Von Neumann Architecture”. 
 
 
 
26. What work did von Neumann do which was instrumental to an Allied victory in World War II? 
 
 
27.  What innovation/development did von Neumann bring to the study of Economics? 
 
 
28. The Transistor was an electrically-controlled switch, much like the vacuum tube or 

electromechanical relay.  Why was it an improvement over the vacuum tube? 
 
 
 



29. Page 83 incorrectly states that the transistor was developed by a team at Stanford.  Where was 
the transistor developed? 

 
 
 
30. What is an Integrated Circuit? 
 
 
 
31. Mainframes and Minicomputers are somewhat archaic concepts in 2013.  What generic term 

do we use today to refer to computers which provide data or computations to many users? 
 
 
 
32. On page 86, the author says “there’s talk of reducing components to molecular size using 

recombinant DNA Technology”.  In March of 2013, a team at Stanford built something called 
“The Transcriptor”.  What is it? 

 
 
 
Part II : Logical Spaghetti 
Some parts of Part II are a little more densely packed with detail (logic circuits, assembly language) 
than Part I and might be difficult for you to follow.  Just do your best to understand and glean the 
key concepts from the reading.   
  
33. What important contribution did George Boole make to the development of the computer? 
 
 
 
34. What is a “Truth Table?” Write the truth tables for AND, OR, and NOT. 
 
 
 
 
35. What is an “AND-gate” ? 
 
 
 
36. Convert the binary number 101011101 to decimal by hand 
 
 
 
 
37. What is a bit and how many possible values can it represent? What is a byte and how many 

possible values can it represent? 



 
 
 
38. What is the difference between an integer and a floating point number? 
 
 
 
39. Why was the development of ASCII important?  What is the ASCII character for 1010111?  

What is the ASCII code for the number for the @ sign? 
 
 
 
 
40. What is the job of an ALU? 
 
 
 
 
41. What special capability does a “flip-flop” circuit have? 
 
 
 
42. What is a register? 
 
 
 
43. What is a clock circuit?  What does it mean when you say that a computer has a “3 Gigahertz 

processor?” 
 
 
 
44. What are the advantages and disadvantages of electronic and electromechanical memory 

devices?  Which parts of a computer represent electronic memory and which represent 
electromechanical memory? 

 
 
 
 
 
45. What is a memory address?   
 
 
46. What is the decimal equivalent of the hexadecimal number D7 ? 
 
 



 
47. What is the difference between RAM and ROM? 
 
 
 
48. What is volatile memory?  What are some examples of volatile and non-volatile memory in 

devices you use? 
 
 
 
49. What is “Moore’s Law” ? 
 
 
 
50. Page 163 talks of 256K memory chips (the year was 1983).  In 2013, you can purchase memory 

chips with 8GB of capacity.  To the closest power of 2, how much more information can be 
stored in an 8GB memory chips than in a 256K memory chip ? 

 
 
 
51. What is the job of a “bus” in the computer? 
 
 
 
52. Each CPU has an “instruction set”.  What is an instruction set? 
 
 
Part III : Software 
In this section, you will read about the history of software 
 
53. Who was Alan Turing and what very important contribution did he make to the Allied efforts in 

World War II? 
 
 
 
54. What is a Turing Machine and why is the concept important? What is a Universal Turing 

Machine? 
 
 
 
 
55. How are von Neumann’s self-reproducing machines like plant or animal cells?  How does a 

computer virus fall under von Neumann’s definition of a self-reproducing machine? 
 
 



 
 
 
 
56. What is an algorithm? 

 
 
 

57. How is a high-level language different than assembly language? 
 
 
 

58. What source code? What is object code? 
 
 
 
 
59. What is the difference between the way a compiler works and the way an interpreter works? 
 
 
 
 
60. What was the first high-level language? 

 
 

61. You should think of a variable as a ____________   ____________ in _____________. 
 
 
 

62. What is an operating system and what purposes does it serve? 
 

 

 

 

63. What is UNIX? Where was it developed? 
 
 
64. Of the four major computer operating systems, Windows 7/8, MacOS, Linux, and ChromeOS, 

which are ancestors of UNIX ? 
 
 
 
 



65. Much of the world’s data, such as your parent’s bank account information, your grades, your 
Amazon.com order history, etc. is stored in a type of database called a “relational database”.  
What is a relational database? 

 
 
 
 
 
66. For scientists, one of the most useful capabilities of computer is simulation.  What are some 

scientific problems for which simulation is used to model a real-world phenomenon? 
 
 
 
 
67. Before the internet, what was the biggest computer system in the world? 
 
 
 
68. What is The Turing Test?  Find an iPhone and ask Siri if she passes the Turing test.  What does 

she say? 
  



 
AP Computer Science Summer Assignment 

Part B 
 

I. Establish your Java Development Environment and Write a “Hello World” Program 
(1) You should download the Java SE Development Kit at 

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html 

Click “Accept License Agreement”, then download and install the version which is matches your 

computer.   Be sure to select the right version (32-bit or 64-bit (x64)) for your computer.  You most 

likely need the 64-bit version.  If your computer is old, you might need the 32-bit version. 

(2) Create a new folder on your computer called APCompSci 

(3) Inside your APCompSci folder create a new folder called MyCode  

(4) Download Eclipse IDE For Java Developers at http://www.eclipse.org/downloads/ to your 

APCompSci folder.  The download will be a zip (compressed) file.  Note that the download is free 

and you need not make a donation to download Eclipse.  After the download has completed right-

click on this zip file and select Extract All to extract the contents into a folder.   This may take a few 

minutes. After the extract is complete, if the folder has a weird name (like eclipse=java-luna-SR2-

win32-x86_64) , right-click on the folder and rename it to eclipse . After you have extract is 

complete, delete the zip file you had downloaded. 

 

(5) Navigate to APCompSci->eclipse->eclipse.  There is an application in this folder called eclipse and 

the icon for this file should look like this:  .  Right-click on this file and select Send to Desktop 

(create shortcut).   This will create a shortcut for eclipse on your desktop 

(6) Go you’re your Desktop and double-click on your newly created Eclipse icon to start Eclipse 

(7) Eclipse might take a little while to start/initialize.  After Eclipse has initialized, it will present a Select 

A Workspace dialog box.  Click on the Browse  button and navigate to your APCompSci->MyCode 

folder.  Check the checkbox for Use this as the default and do not ask again.  Then click OK.   

(8) A Welcome Window is displayed.  If you ever need to return to the Welcome window, select Help-

>Welcome 

(9) On the Welcome Window, select Tutorials, then select Create a Hello World Application. 

(10)  Follow the tutorial instructions and complete all parts of the tutorial. 

 

If you have any questions, email me at rwertz@veronaschools.org 
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AP Computer Science Summer Assignment 

Part C 
 

I. Download the Standard Library Code 
(1) In your APCompSci folder, create a new folder called Jars   

Visit the following link to download and save the file stdlib.jar in your Jars folder.   

http://introcs.cs.princeton.edu/java/stdlib/stdlib.jar 

“Jar” stands for “Java archive” and a jar file is essentially a zip file of useful code.  The code in 

stdlib.jar will help us draw graphics, make sound and manipulate images.  Be sure to just download 

and save this file in your Jars folder and do not try to open it. 

 

II. Configure Eclipse to make “smart” suggestions 
(1) In Eclipse, select Window->Preferences , then in the tree on the left, expand the tree to select Java-

>Editor->Content Assist->Advanced .  On the Advanced window, left-click on the Restore Defaults 

button, then left-click on the OK button. 

(2) In Eclipse, select Window->Preferences , then in the tree on the left, expand the tree to select Code 

Recommenders->Completions .  On the Intelligent Code Completion window, left-click on the Enable 

intelligent code completion checkbox, then left-click on the OK button. 

 

III. Download and run the “Right Triangle” code 

(1) In Eclipse, create a new Java Project (File->New->Java Project) and name the project RightTriangle 

(2) In the Package Explorer window of Eclipse, right-click on the Folder for the RightTriangle project 

and select Build Path->Add External Archives . Then navigate to the stdlib.jar you downloaded in 

your Jars folder and select it.  This step effectively imports some important code that will help us 

draw on the screen 

(3) In the Package Explorer window of Eclipse, right-click on the Folder for the RightTriangle project 

and select New->Class. Then name the new class RightTriangle.  An empty class will appear in the 

editor window of Eclipse.  The Editor window is the window we use to write code. 

(4) Visit the following website 

http://introcs.cs.princeton.edu/java/15inout/RightTriangle.java  

and copy the code in the browser window (click on the browser window and type Control-a, then 

Control-c) 

Then return to the Editor window of Eclipse and paste the copied code (type Control-a, then 

Control-v)  

(5) Right-click on the Editor window and select Run As->Java Application . If a “Save and Launch” dialog 

box appears, check the “Always save resources before launching” and then click OK.  You should 

see a right triangle inscribed in a circle. 

(6) Experiment with this code and see if you can change it and then rerun it to see your change.  Some 

examples might be 

a. Create different shapes 

b. Create shapes that are colored in 

http://introcs.cs.princeton.edu/java/stdlib/stdlib.jar
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c. Draw your name using different shapes 

IV. Download and run the “Bouncing Ball” code 

(1) In Eclipse, create a new Java Project (File->New->Java Project) and name the project BouncingBall 

(2) In the Package Explorer window of Eclipse, right-click on the Folder for the BouncingBall project and 

select Build Path->Add External Archives . Then navigate to the stdlib.jar you downloaded in your 

Jars folder and select it.  This step effectively imports some important code that will help us draw 

on the screen 

(3) In the Package Explorer window of Eclipse, right-click on the Folder for the BouncingBall project and 

select New->Class. Then name the new class BouncingBall.  An empty class will appear in the editor 

window of Eclipse.   

(4) Visit the following website 

http://introcs.cs.princeton.edu/java/15inout/BouncingBall.java 

and copy the code in the browser window (click on the browser window and type Control-a, then 

Control-c) 

Then return to the Editor window of Eclipse and paste the copied code (type Control-a, then 

Control-v)  

(5) Right-click on the Editor window and select Run As->Java Application . If a “Save and Launch” dialog 

box appears, check the “Always save resources before launching” and then click OK.  You should 

see a black ball bouncing on a gray background. 

(6) Experiment with this code and see if you can change it and then rerun it to see your change.  Some 

examples might be 

a. Change the color of the ball or the background 

b. Change the velocity of the ball 

c. Make the ball larger or smaller 

d. Replace the ball with a picture of your pet 

V. Download and run the “GrayScale” code 

(1) In Eclipse, create a new Java Project (File->New->Java Project) and name the project GrayScale 

(2) Save the following JPEG file on your computer by right-clicking on it in your browser and selecting 

“Save Picture As…” 

http://www.veronaschools.org/cms/lib02/NJ01001379/Centricity/Domain/181/1968.jpg 

(3) Drag the saved file into the GrayScale folder in the Package Explorer window of Eclipse.  If you are 

prompted with a “File Operation’ dialog box, select “Copy Files” and click OK. 

(4) In the Package Explorer window of Eclipse, right-click on the Folder for the GrayScale project and 

select Build Path->Add External Archives . Then navigate to the stdlib.jar you downloaded in your 

Jars folder and select it.  This step effectively imports some important code that will help us 

manipulate digital images 

(5) In the Package Explorer window of Eclipse, right-click on the Folder for the GrayScale project and 

select New->Class. Then name the new class GrayScale.  An empty class will appear in the editor 

window of Eclipse.   

(6) Visit the following website 

http://www.veronaschools.org/cms/lib02/NJ01001379/Centricity/Domain/181/GrayScale.txt  

http://introcs.cs.princeton.edu/java/15inout/BouncingBall.java
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and copy the code in the browser window (click on the browser window and type Control-a, then 

Control-c) 

Then return to the Editor window of Eclipse and paste the copied code (type Control-a, then 

Control-v)  

(7) Right-click on the Editor window and select Run As->Java Application . If a “Save and Launch” dialog 

box appears, check the “Always save resources before launching” and then click OK.  You should 

two versions of the jpeg file, one version on top of the other.  You can use the mouse to move the 

two versions side by side to see the differences. 

(8) Experiment with this code and see if you can change it and then rerun it to see your change.  Some 

examples might be 

a. Convert  a picture of your pet to grayscale 

b. Change the program to remove all red and blue from the picture 

c. Only change part of the picture to grayscale 

VI. Download and run the “PlayThatTune” code 

(1) In Eclipse, create a new Java Project (File->New->Java Project) and name the project PlayThatTune 

(2) Save the following Text file on your computer by selecting File->Save As from your browser menu 

http://www.veronaschools.org/cms/lib02/NJ01001379/Centricity/Domain/181/STH.txt  

(3) Drag the saved file into the PlayThatTune folder in the Package Explorer window of Eclipse.  If you 

are prompted with a “File Operation’ dialog box, select “Copy Files” and click OK. 

(4) In the Package Explorer window of Eclipse, right-click on the Folder for the PlayThatTune project 

and select Build Path->Add External Archives . Then navigate to the stdlib.jar you downloaded in 

your Jars folder and select it.  This step effectively imports some important code that will help us 

use the audio capabilities of the computer. 

(5) In the Package Explorer window of Eclipse, right-click on the Folder for the PlayThatTune project 

and select New->Class. Then name the new class PlayThatTune.  An empty class will appear in the 

editor window of Eclipse.   

(6) Visit the following website 

http://www.veronaschools.org/cms/lib02/NJ01001379/Centricity/Domain/181/PlayThatTune.txt 

and copy the code in the browser window (click on the browser window and type Control-a, then 

Control-c) 

Then return to the Editor window of Eclipse and paste the copied code (type Control-a, then 

Control-v)  

(7) Right-click on the Editor window and select Run As->Java Application . If a “Save and Launch” dialog 

box appears, check the “Always save resources before launching” and then click OK.  You should 

hear a song playing on the speakers or headphone jack of your computer. 

(8) Experiment with this code and see if you can change it and then rerun it to see your change.  Some 

examples might be 

a. Change the tempo (fast/slow) of the song 

b. Create another file to have the computer play a tune of your choice 

c. Shift the key of the song to a higher or lower key 

VII. Backup Up Your Work 

(1) Copy your MyCode folder to a USB Flash Drive so that you can bring it to school 
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